[Neubot] problems installing neubot on Linux Mint 13

Simone Basso bassosimone at gmail.com
Wed Oct 17 22:25:00 CEST 2012


Gabriele Bianchi ha scritto:
> Simone Basso ha scritto:
>> Gabriele Bianchi wrote:
>>> I have tried to install neubot on Linux Mint 13 64 bit (based on Ubuntu
>>> 12.04) without success. The program does not start.  I have installed it
>>> logged as root and following the instruction on the Neubot site reserved
>>> to Debian, I have tried to connect to
>>>
>>> http://127.0.0.1:9774/
>>>
>>> without success. I get the message "unable to connect to 
>>> 127.0.0.1:9774".
>>>
>>> I have removed neubot and installed neubot-nox, with similar result. I
>>> have installed via dpkg, via apt-get, via gdebi, via synaptic.
>>>
>>>
>>> I am a linux user since 2005 and I consider myself quite experienced,
>>> but I do not understand what I am doing wrong.
>>
>> Hmm... you don't seem to do anything wrong.
>>
>> To better understand the problem I suggest to:
>>
>> 1. check the system log to see whether there are errors
>>    related to Neubot;
>>
>> 2. attempt to run it in foreground to read directly
>>    the error on the standard output:
>>
>>      # neubot agent -D agent.daemonize=0 -v
>>
>> 3. same as above but logged as yourself, just in case
>>    the `_neubot` user causes troubles:
>>
>>      $ neubot agent -D agent.daemonize=0 -v
>>
>> In case 2. and 3. you can of course interrupt it
>> at any time with ^C.
>>
>> Simone
> I have tried to follow your advices.
> 
> Immediately after boot I login as root. Before issuing any command I 
> find the following lines in the syslog file:
> 
> Oct 17 07:33:05 ginevra /etc/cron.daily/neubot: No need to reenable 
> Neubot repository
> .....
> Oct 17 21:13:04 ginevra neubot agent: No such "simone" user. Exiting

The problem is here.  I just spotted it investigating
a reported by Matteo Castelli on Twitter.  It turns
out your problem and his problem are the same.  As
the diff below explains it comes from a quite great
amount of doofus :-).

Thank you for reporting the bug.  I cannot generate
debian packages right now because I'm away from my
build machine.  I'll roll out another .deb tomorrow
morning.  Once you see the update, please let me
know if it fixes your problem.

Cheers,

Simone

commit b1ba1bf44ca2f148ea54b864add5820faf02801e
Author: Simone Basso <bassosimone at gmail.com>
Date:   Wed Oct 17 22:08:22 2012 +0200

    Makefile: correct serious doofus

    Since $USER is already defined in any UNIX environment, the
    variable is set as `simone` not as `_neubot`.  Reported on
    the mailing list by Gabriele Bianchi and on Twitter by Matteo
    Castelli, thanks!

diff --git a/Makefile b/Makefile
index 17ce1b3..be986bf 100644
--- a/Makefile
+++ b/Makefile
@@ -143,7 +143,7 @@ DATADIR ?= $(PREFIX)/share
 LOCALSTATEDIR ?= $(PREFIX)/var
 MANDIR ?= $(PREFIX)/share/man
 SYSCONFDIR ?= $(PREFIX)/etc
-USER ?= '_neubot'
+NEUBOT_USER ?= '_neubot'

 _install:
 	find . -type f -name .DS_Store -exec rm {} \;
@@ -192,7 +192,7 @@ _install:
 	for PATTERN in 's|@BINDIR@|$(BINDIR)|g' 's|@DATADIR@|$(DATADIR)|g' \
 	        's|@LOCALSTATEDIR@|$(LOCALSTATEDIR)|g' \
 	        's|@SYSCONFDIR@|$(SYSCONFDIR)|g' \
-	        's|@USER@|$(USER)|g'; do \
+	        's|@USER@|$(NEUBOT_USER)|g'; do \
 	    ./scripts/sed_inplace $$PATTERN \
 	        $(DESTDIR)$(BINDIR)/neubot \
 	        $(DESTDIR)$(DATADIR)/applications/neubot.desktop \


More information about the Neubot mailing list